UVa 11054/HDU 1489/POJ 2940 Wine trading in Gergovia(贪心&双向队列)

阿里云国内75折 回扣 微信号:monov8
阿里云国际,腾讯云国际,低至75折。AWS 93折 免费开户实名账号 代冲值 优惠多多 微信号:monov8 飞机:@monov6


11054 - Wine trading in Gergovia

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1995

http://acm.hdu.edu.cn/showproblem.php?pid=1489

http://poj.org/problem?id=2940

As you may know from the comic "Asterix and the Chieftain's Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don't care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

Input Specification

The input consists of several test cases. Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy aibottles of wine, otherwise if ai < 0, he wants to sell -ai bottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

Output Specification

For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type "long long", in JAVA the data type "long").

Sample Input

5 5 -4 1 -3 1 6 -1000 -1000 -1000 1000 1000 1000 0

Sample Output

9 9000



思路:


一开始我想的是用双向队列存储,模仿:1. 顾客排队和售货商的排队 2. 回合制游戏

(注意,就算正数是卖出,负数是买入,结果也是一样的。)


但是,后来我发现不用这么做,

一种新思路:

假设有一辆马车,从左往右行驶,它可以代替人们买卖葡萄酒!你可能会问,如果一开始遇到的都是想买的人呢?可以这么想,从买家到卖家和从卖家到买家是等价的。所以整个程序可以顺序一遍搞定。


完整代码:

双向队列的,慢死了:

PS:在UVaOJ上请使用%lld替代%I64d

/*UVaOJ: 0.065s*/
/*HDU: 62ms,1740KB*/
/*POJ: 375ms,2056KB*/

#include <cstdio>
#include <deque>
#include <algorithm>
using namespace std;

struct node
{
	int pos, num;
} a[100000];

deque<node> buy, sell;

int main()
{
	int n, temp;
	while (scanf("%d", &n), n)
	{
		buy.clear();
		sell.clear();
		node tempbuy, tempsell;
		long long sum = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &temp);
			a[i].pos = i;
			a[i].num = temp;
			if (temp > 0)
				buy.push_back(a[i]);
			else if (temp < 0)
				sell.push_back(a[i]);//注意a[i].num是负数

			//while里面的操作就像回合制游戏一样,你懂的~
			while (!(buy.empty() || sell.empty()))
			{
				tempbuy = buy.front();
				buy.pop_front();
				tempsell = sell.front();
				sell.pop_front();
				if (tempbuy.num + tempsell.num > 0)
				{
					sum -= tempsell.num * abs(tempbuy.pos - tempsell.pos);
					tempbuy.num += tempsell.num;
					buy.push_front(tempbuy);
				}
				else
				{
					if (tempbuy.num + tempsell.num < 0)
					{
						tempsell.num += tempbuy.num;
						sell.push_front(tempsell);
					}
					sum += tempbuy.num * abs(tempbuy.pos - tempsell.pos);
				}
			}
		}
		printf("%I64d\n",sum);
	}
	return 0;
}


新思路:

PS:在UVaOJ上请使用%lld替代%I64d

/*UVaOJ: 0.048s*/
/*HDU: 31ms,228KB*/
/*POJ: 94ms,144KB*/

#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
	int n, a;
	long long temp, ans;
	while (scanf("%d", &n), n)
	{
		temp = ans = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &a);
			temp += a;
            ans += abs(temp);
		}
		printf("%I64d\n", ans);
	}
	return 0;
}




阿里云国内75折 回扣 微信号:monov8
阿里云国际,腾讯云国际,低至75折。AWS 93折 免费开户实名账号 代冲值 优惠多多 微信号:monov8 飞机:@monov6
标签: go

“UVa 11054/HDU 1489/POJ 2940 Wine trading in Gergovia(贪心&双向队列)” 的相关文章

Mysql添加外键的方式有哪些 - 开发技术

本篇内容介绍了“Mysql添加外键的方式有哪些”的有关知识,在实际案例的操作过程中,不少人都会遇到这样的困境,接下来就让小编带领大家学习一下如何处理这些情况吧!希望大家仔细阅读,能够学有所成!Mysql添加外键的几种方式注意:添加外键是给从表添加(即子表)父表是主表方...

快速入门2

字符串 #感觉''与""区别不大嘛 testStr='Python' isCool="is cool!" print testStr[0] print testStr[1:3] print isCool[:2] print isCool[0:] print...

怎么搭建php网站并实现局域网访问 - 编程语言

本篇内容主要讲解“怎么搭建php网站并实现局域网访问”,感兴趣的朋友不妨来看看。本文介绍的方法操作简单快捷,实用性强。下面就让小编来带大家学习“怎么搭建php网站并实现局域网访问”吧! 一、搭建PHP环境首先,搭建PHP网站需要环境支持,即...

php date返回的小时数不对如何解决 - 编程语言

这篇文章主要介绍“php date返回的小时数不对如何解决”的相关知识,小编通过实际案例向大家展示操作过程,操作方法简单快捷,实用性强,希望这篇“php date返回的小时数不对如何解决”文章能帮助大家解决问题。 问题描述在 PHP 中,我...

Pytorch固定随机种子&&复现模型

官网 Reproducibility — PyTorch 1.11.0 documentation 在神经网络中参数默认是进行随机初始化的。不同的初始化参数往往会导致模型的训练结果会存在一定的差异。当得到比较好的结果时我们通常希望这个结果是可以复现的就需要保证每一次初始化的参数都不变这就引入了随机...

SpringBoot入门(二):Controller的使用

Controller中注解的使用:   @Controller   ●该注解用来响应页面,必须配合模板来使用   @RestController ●该注解可以直接响应字符串,返回的类型为JSON格式 1 package com.example.demo....